BMW NineT Forum banner

41 - 60 of 101 Posts

·
Registered
Joined
·
904 Posts
any good priced and sealed battery that you can find that fits the specs for this bike will do $40-$70 or go lithium, or gel it for some more money.

I have not heard of any bad stuff with any battery on this forum so far. Except for the stock that came with it.
Any auto parts store should do it or chain store, batteries plus, walmart, and if you have time internet is great.
 

·
Registered
Joined
·
36 Posts
I was going to give this a go this weekend(Battery Change) - But I see a post by Gambo916 & PetrolPants regarding lifting the tank without disengaging the fuel lines (Something I dread). Is it really possible to lift the tank high enough to swop out the battery without disengaging fuel lines? Is there any trick in doing this? Only lighten the tank with less gas? Sorry for redundant questions - but this is a little scary for me - but I am going to try!


If I do disengage the fuel lines - how much gas from the tank is released? - Only a trickle or all of it?


Thanks
 

·
Registered
Joined
·
9 Posts
I was going to give this a go this weekend(Battery Change) - But I see a post by Gambo916 & PetrolPants regarding lifting the tank without disengaging the fuel lines (Something I dread). Is it really possible to lift the tank high enough to swop out the battery without disengaging fuel lines? Is there any trick in doing this? Only lighten the tank with less gas? Sorry for redundant questions - but this is a little scary for me - but I am going to try!


If I do disengage the fuel lines - how much gas from the tank is released? - Only a trickle or all of it?


Thanks
You won’t lose any fuel, the connectors are quick release and very easy to manage. Obviously the less fuel in the tank the better. The whole process is very easy.
 

·
Super Moderator
2014 Classic
Joined
·
4,416 Posts
No real problems lifting the tank at the rear and the lower the fuel the easier it is.
Make sure you use plenty of rags/padding at the front to protect your paint.
Have a length of timber like a broom handle that is well padded to place across under the tank when you have lifted it.

If you are a bit worried, it's actually easier to take the tank right off, so then it won't be precariously in the way when you swap the battery.

Go on, give it a go! :eek:k:
 

·
Registered
Joined
·
36 Posts
I wanted to write and thank everyone for the encouragement here. I gave it ago, took my time - had a helper and didn't need to disconnect fuel lines. I installed a new Yuasa GYZ16H Battery. The bike fired up like it was on steroids. Thanks Again
[FONT=&quot]
[/FONT]
 

·
Premium Member
Joined
·
406 Posts
Im going to go ahead and pull my tank and replace the battery with a Lithium one before it leaves me stranded. While I have the tank off I'm going to replace the air filter with a BMC one, and swap the throttle pulley.
 

·
Premium Member
Joined
·
406 Posts

·
Registered
Joined
·
34 Posts
Hi everyone,
Sorry to jump in, I hope I'm posting on the right thread....otherwise feel free to tell me off :)

3 months ago I bought a 2015 R Nine T, I noticed right from the get go that the battery was a little "weak", as soon as it sat in the garage for about a week when I went to fire it up it always took a little effort. I've tried charging it through the external plug but as soon as I don't ride it for a few days it's back to square one.

I want to change the battery and yesterday I checked at BMW how much would it cost me just to buy the battery (I'm going to install it by myself) they asked for 1420 AED ($390 USD) for the regular AGM BMW battery......It seems "a little over killed".
I'm happy to buy it on line and install it, I've red a few threads here about Lithium options, but I don't think I wanna go that way.

What do you suggest as brand/model that you've used and have been happy with??

Also, is it normal that when I fire up the bike the dash board reset itself (the needles go back again just like when u first turn the key)?
 

·
Registered
Joined
·
34 Posts
I`ve done a bit of research and I`ve narrowed it down so far to two options:
Yuasa GYZ16H
Yuasa YTX14-BS

If I understood this right the main difference is that the GYZ16H gives out a couple of extra Ah and since I`ve just installed rizoma Club S indicators at the back and rizoma club at the front + the daedalus tail tidy kit I wouldn`t mind the extra juice.

For some reason Amazon seems to believe the GYZ16H wouldn`t feet my bike...
Ethurlow, you`ve installed that successfully, right?

I`ll happily take any advise!!
 

·
Registered
Joined
·
445 Posts
I`ve done a bit of research and I`ve narrowed it down so far to two options:
Yuasa GYZ16H
Yuasa YTX14-BS

If I understood this right the main difference is that the GYZ16H gives out a couple of extra Ah and since I`ve just installed rizoma Club S indicators at the back and rizoma club at the front + the daedalus tail tidy kit I wouldn`t mind the extra juice.!
If your decision is down to these two, go for the GYZ16H, not so much for the Ah rating but the CCA rating.
This big 1200 needs every amp to crank it over sufficiently.

Don't worry about running power; these 9Ts have a massive 720w alternator on them. You could power a sun! :cool2:
 

·
Registered
Joined
·
34 Posts
If your decision is down to these two, go for the GYZ16H, not so much for the Ah rating but the CCA rating.
This big 1200 needs every amp to crank it over sufficiently.

Don't worry about running power; these 9Ts have a massive 720w alternator on them. You could power a sun! :cool2:
Thanks LoRez,

I have narrowed it down to that just based on what I've red around this forum, but if you have some alternative suggestion I'm all ears!

I am concerned about the running power because when I have installed my new tail tidy kit and rizoma club s indicator I can only get one running light to work. Essentially if I don't connect the club S everything works fine with the tail tidy (running/break/integrated indicators) but when I plug the rizoma club S the running light stops working on the tail tidy (but it works on the rizoma club s), as if the load was too much to handle for the battery.
My battery has been weak ever since I bought the bike, it takes a few seconds to start after just 4-5 days in the garage, so I thought that it was time to change it anyway and I was hoping I could solve that problem too.
I have tried recharging the battery, but that didn't do the trick for the running light.

Also, just to be sure (I'm getting paranoid now) is the dashboard supposed to "reboot" itself when you start the engine?
See video attached.


Thanks!
 

·
Registered
Joined
·
34 Posts
Thanks LoRez,

I have narrowed it down to that just based on what I've red around this forum, but if you have some alternative suggestion I'm all ears!

I am concerned about the running power because when I have installed my new tail tidy kit and rizoma club s indicator I can only get one running light to work. Essentially if I don't connect the club S everything works fine with the tail tidy (running/break/integrated indicators) but when I plug the rizoma club S the running light stops working on the tail tidy (but it works on the rizoma club s), as if the load was too much to handle for the battery.
My battery has been weak ever since I bought the bike, it takes a few seconds to start after just 4-5 days in the garage, so I thought that it was time to change it anyway and I was hoping I could solve that problem too.
I have tried recharging the battery, but that didn't do the trick for the running light.

Also, just to be sure (I'm getting paranoid now) is the dashboard supposed to "reboot" itself when you start the engine?
See video attached.


Thanks!
Sorry LoRez,

I think the attachment with the video of my dashboard did not go through the first time....my apologies, I'm still learning here.
Let's try again.
 

Attachments

·
Administrator
Joined
·
12,190 Posts
Hi there, the dash should not reboot itself after the bike is running, the instrument cluster self-test sequence should only happen when the ignition is turned on, and before you push the starter switch.

I'm guessing that battery you are talking about replacing will be the culprit, but I doubt would be responsible for the other electrical issues you mention.
 

·
Registered
Joined
·
36 Posts
Hi Corrado - I did install the Yuasa GYZ16H Battery. It fit perfectly and has functioned flawlessly since installing. With a helping hand and advice in this thread from PetrolPants and Gambo916 I was able to squeeze it in without removing the tank. I bought it from Revzilla - a large distributor here in the states.


Give it a go - I hope it fixes your issues.
 

·
Registered
Joined
·
445 Posts
Thanks LoRez,

I have narrowed it down to that just based on what I've red around this forum, but if you have some alternative suggestion I'm all ears!

I am concerned about the running power because when I have installed my new tail tidy kit and rizoma club s indicator I can only get one running light to work. Essentially if I don't connect the club S everything works fine with the tail tidy (running/break/integrated indicators) but when I plug the rizoma club S the running light stops working on the tail tidy (but it works on the rizoma club s), as if the load was too much to handle for the battery.
My battery has been weak ever since I bought the bike, it takes a few seconds to start after just 4-5 days in the garage, so I thought that it was time to change it anyway and I was hoping I could solve that problem too.
I have tried recharging the battery, but that didn't do the trick for the running light.

Also, just to be sure (I'm getting paranoid now) is the dashboard supposed to "reboot" itself when you start the engine?
See video attached.


Thanks!
As @BaldyDave said that "rebooting" dash isn't normal if the bike is already running.

Your running light woes sound like an install problem that shouldn't have anything to do with battery or running power.
More like the resistance is beyond programmed parameters and the ECU is shutting them down.
There are plenty of threads in the Electronics section regarding this.

I would have probably gone for the Yuasa GYZ16H too if I hadn't moved to an Antigravity Lithium battery. :)
 

·
Registered
Joined
·
34 Posts
Thanks guys,
I much appreciate the help.

I've ordered my battery on line, now is going to take a few days before I get a Yuasa out here, but I'll keep you posted!
Regarding the dashboard, I really hope the battery will solve that issue, I'm gutted I didn't spot it at first when I tested the bike. Hopefully that will be all.

For the running lights, I agree with you and I'm trying to sort it out with the Daedalus guys since I bought the whole kit from them.
Fingers crossed!
 

·
Registered
Joined
·
34 Posts
Hey guys,
My order for the battery has been canceled, unfortunately the local regulation do not allow the battery to be shipped...I've searched a lot locally (to avoid going to the dealership at an extortion price), but I can`t seem to find Yuasa batteries. It`s mostly all chinese batteries or dealership.

I found a shop that sells for a reasonable price BS BTX14H SLA (see attached). Does anyone have any experience or info about these battery???

Thanks!
 

Attachments

·
Registered
Joined
·
34 Posts
Hi everyone,
just to close off this mini saga and give a feedback about this battery in case anyone come across it.

I`ve finally purchased and installed the battery today the BS BTX14H SLA was the best thing I could find around here without going to the dealership.

Installing it was a pain (they honestly couldn`t have found a more awkward place to put it) but with a pair of helping hands holding the tank it went as smooth as it could.
As magically predicted, the bike starts right up and no more dashboard rebooting.
The issue with the running light is still there, but the Daedalus guys gave me a temporary fix while they send me a new board. Right now the Club S at the back are working like regular Club, but other then that everything works fine.

I took the opportunity to install the phone charger as well.
It was a great maintenance day! :)

Thanks everyone for the advice.

See couple of pics attached of the job done.
 

Attachments

41 - 60 of 101 Posts
Top