BMW NineT Forum banner

1 - 20 of 21 Posts

·
Registered
2018 BMW r nineT Pure
Joined
·
170 Posts
You should have two plugs in you’re wiring harness, one for US and one for EU so shouldn’t get an error
 

·
Premium Member
Joined
·
2,286 Posts
It appears to depend on the bike you’re putting it on. My 2018 bike isn’t throwing any errors at all.
Have you actually plugged it into a GS911 or dealer computer to verify that? The ECU is programmed to recognize a specific current draw through the CANBUS. US models are programmed for the US taillight and dealers don't have a program to run to update it because it isn't an option. It's the same as installing any other non-OEM taillight. The dash light would flash intermittently - so it's possible you just haven't noticed it.
 

·
Premium Member
Joined
·
2,286 Posts
No. I haven’t. I’ve put more than a few miles since the switch and haven’t noticed any error. Including some interstate droning. If I don’t see an error and it doesn’t impact the function of the bike, does it matter?
If you say it doesn't matter to you, it absolutely doesn't matter. That may not be the case for everyone. I'm just trying to verify if the ECU update on later models legitimately fixed the issue - it's useful info for when people inquire (as above). I (former 2014) rode with the error and intermittent dash light for quite a while - it didn't bother me - but I eventually threw a resistor in the US plug to eliminate it.
 

·
Registered
Joined
·
73 Posts
Discussion Starter #12
Where do I put the resister? I do have one but this "kit" was made up by another owner with no instructions.
 

·
Premium Member
Joined
·
2,286 Posts

The top pic in this post shows the plug and resistor.
 

·
Registered
Joined
·
14 Posts
I bought the Evo Tech tail tidy (US version) that comes with the Euro tail light. Installed with no error issues. I don't know if it's an OEM tail light that came in the kit though.

Previously, I had replaced my bulb indicators with OEM LEDs and had error code appear. You can check my post on how I fixed that if interested/applicable.
 

·
Registered
Joined
·
47 Posts
I have a 2015 NineT that I just replaced the US taillight with the BMW Euro taillight. I have not gotten any codes that I am aware of or Bulb Out notice on my gauge. I also have the rear turn signals removed while waiting on parts and as soon as I hit the TS button on the switchgear it show Bulb Out. so I know it's working.

BTW, my bike wiring harness has two plugs, one large for the US TL and one small that had a plastic cap for the EU.
 
1 - 20 of 21 Posts
Top