BMW NineT Forum banner
  • Hey Everyone! Enter your bike HERE to be a part of this months Bike of the Month Challenge!
641 - 660 of 687 Posts

·
Registered
Joined
·
16 Posts
Got my ‘21 scrambler and curious trying this method.
I disconnected the cables and i hear a little loud but seen the engine light. Now, i put it back and the engine is still there WTF..

is this going away itself after few on, start, off method?
 

·
Registered
Joined
·
201 Posts
Got my ‘21 scrambler and curious trying this method.
I disconnected the cables and i hear a little loud but seen the engine light. Now, i put it back and the engine is still there WTF..

is this going away itself after few on, start, off method?
You must have done something wrong, could you take pictures of what you've done ?
 

·
Registered
Joined
·
16 Posts
You must have done something wrong, could you take pictures of what you've done ?
Ill try later on but as it is. I properly placed them back as they coiled. You can’t go wrong with the cables as they have hole indication and the electronic switch was switched back properly as well
 

·
Registered
2021 R NineT Scrambler
Joined
·
94 Posts
I think that's why you got a fault on your dial, with the modification described by Euler's Identity, you don't have to disconnect the servo, only the wires from the servo to the flap.
 

·
Registered
Joined
·
201 Posts
The servo wire with connector
Why did you disconnect it? You didn't have to.

I'd be willing to bet that your engine fault light is coming from that, simply because there is no way for the ECU to know that the cables have been disconnected from the valve assembly. It most definitely knows however, whether you've disconnected a servo wire or not.
 

·
Registered
Joined
·
16 Posts
Why did you disconnect it? You didn't have to.

I'd be willing to be that your engine fault light is coming from that, simply because there is no way for the ECU to know that the cables have been disconnected from the valve assembly. It most definitely knows however, whether you've disconnected a servo wire or not.
I need to disconnect so i can have a room for removing those 3 T20 torx and disconnect the coil wires. My dilemma now is everything was placed as it is but still getting the triangle light
 

·
Registered
Joined
·
201 Posts
B
I need to disconnect so i can have a room for removing those 3 T20 torx and disconnect the coil wires. My dilemma now is everything was placed as it is but still getting the triangle light
I haven't yet performed that modification on a Scrambler, but it seems to be pretty similar from the headers down to the flapper valve.
I might be wrong though.

My plastic valve housing only had 2 Torx screws to remove.

Anyway : you may want to reset your ECU. You might do that with a scanner or by disconnecting the battery.

However, I'd be very curious to see some pictures of the assembly on a Scrambler as I don't have access to one.
 

·
Registered
2021 R NineT Scrambler
Joined
·
94 Posts
It's the same as you pictured in your step by step mod upper in the comments.
You have to remove the servo to open it, to unhook the servo cables from it (clean removal of cables)
I think the problem here is that he powered on the bike while the servo was disconnected from the ECU, thus the dial warning.

From what I got from your step by step procedure, here's what I'll be doing instead:

(Clean removal procedure)
1-power down bike
2-remove servo (screw and electrical connection)
3-open servo
4-unhook cables
5-closeup servo
6-replug and screw back servo
7-open flapper plastic cap
8-remove cable
9-close back flapper cap
10-power on bike

(easy removal procedure)
your procedure Euler'S identity
 

·
Registered
Joined
·
201 Posts
It's the same as you pictured in your step by step mod upper in the comments.
You have to remove the servo to open it, to unhook the servo cables from it (clean removal of cables)
I think the problem here is that he powered on the bike while the servo was disconnected from the ECU, thus the dial warning.

From what I got from your step by step procedure, here's what I'll be doing instead:

(Clean removal procedure)
1-power down bike
2-remove servo (screw and electrical connection)
3-open servo
4-unhook cables
5-closeup servo
6-replug and screw back servo
7-open flapper plastic cap
8-remove cable
9-close back flapper cap
10-power on bike

(easy removal procedure)
your procedure Euler'S identity
Ok, so you have to remove the servo in order to to then remove the plastic flapper valve on the scrambler or do you do it only to remove cables from the servo to the flappper valve ?
 

·
Registered
2021 R NineT Scrambler
Joined
·
94 Posts
Ok, so you have to remove the servo in order to to then remove the plastic flapper valve on the scrambler or do you do it only to remove cables from the servo to the flappper valve ?
Yeah, you do it only to remove cables from the servo to the flappper valve.
I've amended your procedure and renamed it the ''clean removal'' (still it leaves us with the plastic cap over the flapper valve remaining in place); that way the servo stays in place (no fault) and the cables have been removed. I'll be performing it tonight to test, but I think it should work.
 

·
Registered
Joined
·
201 Posts
Yeah, you do it only to remove cables from the servo to the flappper valve.
I've amended your procedure and renamed it the ''clean removal'' (still it leaves us with the plastic cap over the flapper valve remaining in place); that way the servo stays in place (no fault) and the cables have been removed. I'll be performing it tonight to test, but I think it should work.
Cool, keep us posted. If it all works out OK, which it should, I'll edit the post.

I guess that the procedure highlighted in the instruction post could be thought of as a quick and dirty method indeed, that's perhaps most adapted to someone who'd just like to try it out.

I don't mind the cables though, so mine will stay as is.
 

·
Registered
2021 R NineT Scrambler
Joined
·
94 Posts
Cool, keep us posted. If it all works out OK, which it should, I'll edit the post.

I guess that the procedure highlighted in the instruction post could be thought of as a quick and dirty method indeed, that's perhaps most adapted to someone who'd just like to try it out.

I don't mind the cables though, so mine will stay as is.
Hello Euler's Identity, it is confirmed, my procedure works like a charm. Takes about 10 minutes to complete and sounds so good. It's just a little throatier, but oh so perfect!
No ECU error warning showing on the dial.
Here are the updated steps.


(Clean removal procedure)
1-power down bike
2-remove servo (screw and electrical connection)
3-open servo
4-unhook cables
5-closeup servo
6-replug and screw back servo
7-open flapper plastic cap
8-remove cable
9-close back flapper cap
10-power on bike
11-enjoy the sound

optional steps:
-get yourself a servo buddy to get rid of the whole servo altogether ;)
 

·
Registered
Joined
·
16 Posts
So the servo connection is a mortal sin to disconnect. I disconnect mine and put back and still have the check engine.
 

·
Registered
2021 R NineT Scrambler
Joined
·
94 Posts
So the servo connection is a mortal sin to disconnect. I disconnect mine and put back and still have the check engine.
Probably not, but it’s only normal that the fault is there. When you power on the bike, the ECU checks his systems; “hey where’s that servo at?!? I better pop a warning on the main dial!” So even if you turn it off and plug it back, the fault is gonna stay there for the next service technician to look at and reset. If you want to get rid of the servo, you have to buy a servo buddy; a small wire extension that make the ECU believe that the servo is still there.
 

·
Registered
Joined
·
201 Posts
So the servo connection is a mortal sin to disconnect. I disconnect mine and put back and still have the check engine.
Probably not, but it’s only normal that the fault is there. When you power on the bike, the ECU checks his systems; “hey where’s that servo at?!? I better pop a warning on the main dial!” So even if you turn it off and plug it back, the fault is gonna stay there for the next service technician to look at and reset. If you want to get rid of the servo, you have to buy a servo buddy; a small wire extension that make the ECU believe that the servo is still there.
Or you could @ad78 try to disconnect the battery, push on the horn for a minute or so, then reconnect the battery and restart the bike. That could/should reset the ECU, and if it finds the servo straight away it won't have anything to complain about.
 

·
Registered
Joined
·
201 Posts
Hello Euler's Identity, it is confirmed, my procedure works like a charm. Takes about 10 minutes to complete and sounds so good. It's just a little throatier, but oh so perfect!
No ECU error warning showing on the dial.
Here are the updated steps.


(Clean removal procedure)
1-power down bike
2-remove servo (screw and electrical connection)
3-open servo
4-unhook cables
5-closeup servo
6-replug and screw back servo
7-open flapper plastic cap
8-remove cable
9-close back flapper cap
10-power on bike
11-enjoy the sound

optional steps:
-get yourself a servo buddy to get rid of the whole servo altogether ;)
I've added a link to this post on the original one. Thanks @LWIRWA ;-)
 
641 - 660 of 687 Posts
Top